Papirfly - Investigating Core Service Outage – Incident details

Third Party: Cloudflare → Cloudflare Sites and Services → Infrastructure experiencing degraded performance

Investigating Core Service Outage

Resolved
Major outage
Started 15 days agoLasted about 2 hours

Affected

Cloud Services

Major outage from 9:18 AM to 9:34 AM, Degraded performance from 9:34 AM to 9:45 AM, Operational from 9:45 AM to 10:46 AM, Degraded performance from 10:46 AM to 11:27 AM

Papirfly Cloud Services

Major outage from 9:18 AM to 9:34 AM, Degraded performance from 9:34 AM to 9:45 AM, Operational from 9:45 AM to 10:46 AM, Degraded performance from 10:46 AM to 11:27 AM

Place

Major outage from 9:18 AM to 9:34 AM, Degraded performance from 9:34 AM to 9:45 AM, Operational from 9:45 AM to 10:46 AM, Degraded performance from 10:46 AM to 11:27 AM

Point

Major outage from 9:18 AM to 9:34 AM, Degraded performance from 9:34 AM to 9:45 AM, Operational from 9:45 AM to 10:46 AM, Degraded performance from 10:46 AM to 11:27 AM

Plan

Major outage from 9:18 AM to 9:34 AM, Degraded performance from 9:34 AM to 9:45 AM, Operational from 9:45 AM to 10:46 AM, Degraded performance from 10:46 AM to 11:27 AM

Produce

Major outage from 9:18 AM to 9:34 AM, Degraded performance from 9:34 AM to 9:45 AM, Operational from 9:45 AM to 10:46 AM, Degraded performance from 10:46 AM to 11:27 AM

Updates
  • Resolved
    UTC
    Resolved

    The performance issues have been mitigated, and all services have currently returned to standard operational parameters.

    Our engineering team has completed the infrastructure reconfiguration, and the expanded capacity (additional nodes, CPU, and memory) has successfully relieved the system bottleneck. While the environment is now stable, we are keeping the platform under intensive monitoring over the next few hours to ensure long-term stability and prevent any recurrence.

    We apologize for the disruption experienced today and thank you for your continued patience.

  • Identified
    UTC
    Identified

    We are currently experiencing degraded performance and increased response times across our platform. Our engineering team is actively expanding our core infrastructure capacity and scaling our internal services to alleviate the system load and restore normal performance. We sincerely apologize for the recurrence of this issue and will keep you updated here.

  • Resolved
    UTC
    Resolved

    We would like to apologize for the temporary service unavailability experienced by our users earlier today.

    The disruption was caused by an unexpected performance bottleneck within our internal search and indexing infrastructure, which led to a cascade failure across our core application services. Once the root cause was identified, our engineering team successfully isolated the affected component, stabilized the data indexing layer, and initiated a controlled recovery process. All services have now been safely restored to full operational capacity.

    We are currently reviewing our infrastructure architecture and monitoring alerts for this specific component to prevent similar occurrences in the future. Thank you for your continued patience and understanding.

  • Identified
    UTC
    Identified

    We have identified and mitigated the underlying infrastructure issue that caused the service disruption. Most services are now recovering and coming back online. We are closely monitoring the system performance to ensure full stability. Thank you for your patience.

  • Investigating
    UTC
    Investigating

    We are aware of a critical issue causing widespread service unavailability across our platform. Our team is urgently investigating the situation to restore functionality. Next update will be provided within 30 minutes.