Papirfly - Service Degradation (Database Performance Issues) – Incident details

Third Party: Cloudflare → Cloudflare Sites and Services → Infrastructure experiencing degraded performance

Service Degradation (Database Performance Issues)

Resolved
Major outage
Started 24 days agoLasted 39 minutes

Affected

Cloud Services

Major outage from 12:54 PM to 1:33 PM

Papirfly Cloud Services

Major outage from 12:54 PM to 1:33 PM

Place

Major outage from 12:54 PM to 1:33 PM

Point

Major outage from 12:54 PM to 1:33 PM

Plan

Major outage from 12:54 PM to 1:33 PM

Produce

Major outage from 12:54 PM to 1:33 PM

Updates
  • Postmortem
    UTC
    Postmortem

    We would like to apologize for the intermittent service degradation and connectivity issues experienced by some of our users earlier today.

    During a background system optimization process initiated late last week, an unexpected accumulation of data occurred within our core storage environment over the weekend. This led to temporary system congestion and performance slowdowns today. Our engineering team proactively managed system traffic and expanded infrastructure capacity to fully stabilize the environment. All services were safely restored to full operational capacity within 120 minutes.

    We are adjusting our system maintenance protocols to ensure that background tasks do not impact performance in the future. Thank you for your patience and understanding.

  • Resolved
    UTC
    Resolved

    The database load issues have been successfully mitigated, and all services are now fully operational.

    We are continuously monitoring the system's performance to ensure stability. A post-incident review will be conducted internally to prevent future occurrences.

    Thank you for your patience and understanding while we resolved this issue.

  • Identified
    UTC
    Identified

    Access to the majority of our services should now be restored, and performance is returning to normal levels.

    While systems are currently stable, our engineering team is continuing to thoroughly investigate the root cause of the database load to ensure long-term stability and prevent this from happening again.

    We will provide a final update once the investigation is complete and the incident is officially resolved. Thank you for your patience.

  • Investigating
    UTC
    Investigating

    We are currently experiencing high load on our core database systems, which may result in slow response times or intermittent unavailability across some of our services.

    Our engineering team is actively investigating the root cause and working on stabilizing the environment.

    We sincerely apologize for any inconvenience this may cause. We will provide updates on this page as more information or an Estimated Time of Resolution (ETR) becomes available.